Advertisements

nVidia Graphic card not being detected and does not show up on the Device Manager

Hi,

Just today morning, my laptop had suddenly started acting weird. One of the graphic cards, nVidia, was not being detected. Each time I tried to reinstall the driver it kept saying that there was no nVidia GPU found on my laptop. It was too quite unreal for me because everything was just fine until yesterday. I went ahead and uninstalled all the programs and the driver that were related to nVidia. I then went to the Device Manager to check for the Graphic card, to my shock, there was nothing listed there. However when I checked if it was listed in the hidden devices option, surprisingly not just one but 2 graphic cards (not even the model that was installed on the laptop) were present. I deleted them all and tried to do a Scan Hardware change, but it didn’t fetch any result at all! By this time, I had completely sunk in thoughts about what had happened to my laptop in one night!

I then went to the nVidia website and tried to make it do an autodetect. It failed! The next stop was the manufacturer’s website and I downloaded the default driver from there. It still wasn’t working. I then started researching on the issue quite much. There was no answer until I stumbled upon a question that was posted on Microsoft forums by someone by the name DU. I read through it until my eyes got stuck on what this user had written on the 2nd page of this post. The link above takes you to the same page and not the first page. His laptop was an Asus and it had similar issues as mine. However when he contacted Asus regarding his problems after having gone through all the steps in the forum to resolve this issue, he got a very surprising yet a working solution! They asked him to do a “restore default BIOS”. I’m not sure how, but yes this worked for me after hours of breaking my brains over this issue. PS:This option may appear in different names with different brand of laptops. You will come to know why. Read through!

You can get into the BIOS settings of your laptop/desktop in different ways set by the manufacturer. You can try to run a google search if you do not know how to get to the BIOS settings of your laptop/desktop. However on my laptop which is a Lenovo Z400, you need to first shut it down. Once powered off completely there’s a small button to the left of the laptop (which is called Novo Key I suppose) just beside the power outlet. Just press this button for a few seconds and release it. This powers on the laptop once again but goes to a screen where it asks for a few options.

First Screen after Novo Press - Lenovo Z400

Scroll down and enter the BIOS Setup option.

Inside BIOS Settings - Lenovo Z400

Go to the last tab, Exit, and look for the option OS Optimized Defaults.

Restore Default Bios - Lenovo Z400

This on my laptop is the equivalent of “Restore Default Bios”. I got to know this by reading it’s description on the right hand side of the BIOS menu. Each menu had a description on what it does. No magic here! Just logic!

Once done, the PC boots back normally. Go to Device Manager, and you should find the graphic card listed back! I then tried to install the driver and this time it worked! It very well detected the graphic card and sanity was restored!

Advertisements

Posted on June 27, 2015, in Windows 8.1 and tagged , , . Bookmark the permalink. Leave a comment.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: